ホーム 開発支援情報 よくあるご質問 SDKについて iOS版のSDKは 最新の Xcode で動作しますでしょうか?

SDKについて

iOS版のSDKは 最新の Xcode で動作しますでしょうか?

Xcode6.x でサンプルプロジェクトを開いた場合,デフォルトのビルド設定 "$(ARCHS_STANDARD)" が 64ビット(arm64)アーキテクチャを含むようになります。
しかし,SpeechRecSDK は 32ビットのスタティックライブラリのため,リンカエラーとなります。

[対策]
サンプルプロジェクトの "Build Settings" の "Architectures" の設定を,"$(ARCHS_STANDARD)" から"$(ARCHS_STANDARD_32_BIT)" に変更することで,32ビットでビルドされるようになります。

お問い合わせ
「docomo Developer support」及び「作ろうスマートフォン/iモードコンテンツ」に関するお問い合わせです。よくあるご質問や技術ブログで解決しない場合は、お問い合わせください。